The planned reinstallation of the full configuration completed successfully and restored connectivity with all upstreams. No outage occurred at any time before or during the maintenance. After the successful commit, we performed step-by-step debugging on the router and were able to pinpoint the exact trigger of the bug, which we will report to Juniper together with our findings.
Posted Dec 03, 2025 - 01:42 CET
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 03, 2025 - 00:30 CET
Scheduled
Please note that there is currently no impact on our overall network availability.
We have encountered a critical Junos software bug on one of our Juniper MX routers, taking multiple upstream sessions offline. All traffic is currently handled by the remaining upstreams and full redundancy is preserved. There was no traffic disruption or outage when the bug occurred, and all services are operating normally.
To stabilise the router, we need to perform emergency maintenance on short notice. During this maintenance, we will re-install the router's configuration in a controlled manner, which is expected to resolve the issue.
We will carry out this work as cautiously as possible and do not plan for any downtime as part of the maintenance. However, depending on the router's behaviour and any additional steps that may become necessary, we cannot fully rule out a temporary loss of connectivity.
We will update this announcement as soon as new information becomes available.
Customers with BGP sessions to dataforest are advised, as a precaution, to shift their traffic away from our network before the maintenance window begins.
Posted Dec 02, 2025 - 14:51 CET
This scheduled maintenance affected: [dataforest Backbone] Interxion FRA8 (Edge Network (affects all locations)).