The maintenance was successfully completed without any unforeseen issues or outages. During the individual line card reboots, minimal packet loss (~ 1%) occurred within a one- to two-second time frame, which was expected. Full redundancy and capacity have been restored.
Posted Feb 01, 2025 - 03:08 CET
In progress
During the preparation work currently in progress, we traced the root cause to a known Junos OS bug triggered by a routine commit operation related to the DDoS protection packet loss issue a few hours earlier (see https://status.dataforest.net/incidents/p27xf22kllpt).
Given the nature of the bug, we have decided not only to remove the specific configuration elements that triggered it during the upcoming maintenance window - this being the official workaround recommended by our vendor, Juniper Networks - but also to reboot all line cards and routing engines in the affected router as a precautionary measure.
Since all components are fully redundant, no service impact is expected. Should any unforeseen issues arise, we will immediately update this status post.
A software update that mitigates the bug will be implemented in the coming months during a separate maintenance window. For that update, the affected PoP will be fully drained of traffic beforehand to prevent any customer impact. As removing the problematic configuration resolves the immediate issue, this update, which requires additional preparation time, is no longer urgent.
Posted Feb 01, 2025 - 02:06 CET
Scheduled
Following a global increase in network latency (~200–400 ms) observed at 19:25 CET for approximately two minutes, we identified a malfunctioning Packet Forwarding Engine (PFE) in our active edge router. The router automatically disabled the faulty PFE, leading to an immediate recovery of services. Until its deactivation, traffic routed through the affected PFE experienced degradation.
Thanks to our redundant network architecture, no global outage occurred; however, latency-sensitive applications may have experienced severe delays.
During the upcoming maintenance window, we will reboot the line card hosting the affected PFE. This action is not expected to impact the network, but a residual risk remains.
Posted Jan 31, 2025 - 19:47 CET
This scheduled maintenance affected: Interxion FRA8 (Edge Network).